Inconsistent graph behaviour when using parent-child tables

CODAP Forums CODAP Help Forum Inconsistent graph behaviour when using parent-child tables

This topic contains 4 replies, has 3 voices, and was last updated by  Anna Fergusson 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #564 Score: 0

    Anna Fergusson

    Kia ora!

    I used CODAP during a workshop I ran with teachers today as part of my data science education PhD research. Part way through an activity working with parent/child (hierarchical) tables, my teachers identified a potential issue!

    Below are two screenshots where the graph displayed is different even though the structure of the data tables is the same. The issue is related to dragging a variable on/off (?) the parent table to/from the child table.


    In between the screenshots shown, the name variable was dragged on to the parent table and then dragged off again.

    In my live demo everything worked fine, but the teachers in their own explorations got a little bit stuck. However, to put a positive spin on the experience, it was great that the teachers could spot there was an issue 🙂

    Sometimes, if you select a group of points on the graph (or rows in the table) the graph “refreshes” and corrects itself (I’m assuming/hoping correct is the first graph!), other times nothing changes.

    Here is a link to a GIF that shows another reproduction of the issue 🙂

    I’m using version 2.0 (0444) BTW.

    Regards Anna


    Jonathan Sandoe

    Hi Anna,

    Thank you for your excellent description of this issue. It is clearly a bug. I have filed a bug report ( I hope we can have a fix, soon.



    Anna Fergusson

    Thanks Jonathan.

    In terms of feature requests, where is the best place to post/request these?



    Bill Finzer

    Hi Anna,

    Thanks for the bug report!

    I think this Help forum is a great place for feature requests ’cause then others can comment and/or +1 them.



    Anna Fergusson

    Great to know. Thanks Bill.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.